| |
NewswireTODAY - /newswire/ -
Muko, Kyoto, Japan, 2006/09/20 - ageet Corporation, experienced makers of VoIP software products such as the softphone AGEphone and the world's smallest VoIP engine microSIP stack, are proud to announce their new series of revolutionary VoIP products: microSIP WEb Object.
|
| |
microSIP Web Object including AGEphone Web Sidebar and AGEphone Web Support. These products are ActiveX plug-ins that allow you to make and receive phone calls to and from landline or mobile phones directly in your web browser. The new products will be available from 09/20/2006.
AGEphone Web Sidebar
AGEphone Web Sidebar is an ActiveX plug-in that allows you to make and receive phone calls to and from landline or mobile phones directly in your web browser when browsing a web page. Customers viewing your page can call you on the spot. The sidebar can be easily integrated into web pages, forums and weblogs.
• Users viewing a page with integrated AGEphone Web Sidebar not only can call you, you can also call them back
• Super Small Size: 150 kbyte download (including skin and sound files) - not larger than a usual image file!
• Downloaded and installed via the browser - no separate application download or configuration required
• Current IP telephone services can be used, calls from and to landline and mobile phones are possible
• You are free to choose whatever IP service provider you like
• Web contents such as links can be dynamically altered on call events
• Protects your privacy: Users can call you without you having to publish your number
• Protects the privacy of your users: Users calling you do not need to use their private accounts
• Calls can be completely anonymous.
AGEphone Web Support
AGEphone Web Support is a simplified version of AGEphone Web Sidebar especially designed to meet the needs for online support scenarios, but also applicable to any other page that does not require the full features of Web Sidebar.
• Easy to use interface - your call is just one click ahead.
• Super Small Size: 130 kbyte download (including skin and sound files) - not larger than a usual image file!
• Make calls to a fixed number such as a support hotline.
• Offers the same features as Web Sidebar.
microSIP Web Object
AGEphone Web Sidebar and AGEphone Web Support are based on the microSIP Web Object, a condensed VoIP engine for ActiveX without any GUI or sound files. It is small, well structured and highly customizable.
The microSIP Web Object works as a software phone, offering nearly all functions available in the microSIP stack. It will be available as an SDK to developers who wish to create their own VoIP Web application.
Features:
• Digest Authorization by Realm
• NAT traversal (UPnP and STUN)
• Inband DTMF send and RFC2833
• Multi-register, multi-session
• Multiple Codecs
• Multi-network interface (NIC) (including VPN)
• Voice Jitter Absorption
• Voice Activity Detection with fade-out
• Hold Function, Hold-Receive Function (receiving by re-inviting)
• Session Timer Support (refresher uac/uas)G.711 u-law/a-law, GSM6.10
RFCs:
• RFC3261: SIP: Session Initiation Protocol
• RFC2327: SDP: Session Description Protocol
• RFC1889: RTP: A Transport Protocol for Real-Time Applications
• RFC2833: RTP Payload for DTMF Digits, Telephony Tones and Telephony Signals
• RFC3489: STUN - Simple Traversal of User Datagram Protocol (UDP) Through Network Address Translators (NATs)
• RFC3581: An Extension to the SIP for Symmetric Response Routing
UPnP: Universal Plug and Play IGD
Platforms:
• Internet Explorer 4.1 or later
• Minimal Size, Easy Installation
With this new series of products, ageet continue their philosophy of providing high quality software at minimal size and operation requirements. Both AGEphone Web Sidebar and AGEphone Web Support (including GUI and sound files) are not larger than a usual image file found on any homepage, yet offer full VoIP functionality.
The user will only need to download a small file, and will be prompted for a quick and easy installation only once. After installation the plug-in can be continuously used just like a Flash Player or PDF Reader.
Simple and Safe Integration
Integration of AGEphone Web Sidebar and AGEphone Web Support is very simple. Just a few easy steps are necessary. To actually use one of the plug-ins on your page, all you have to do is paste a few lines of code into your HTML code, like in this example:
OBJECT ID="WebAGEphone"
style="WIDTH: 148px; HEIGHT: 240px"
classid="clsid:B6669953-7FEF-47FE-ABBF-482DE1979001"
codebase="WebAGEphone.cab#version=1,0,2,6"
PARAM NAME="Callto" VALUE="764705"
PARAM NAME="ReadyText" VALUE="Call Me"
/OBJECT
There is an Integration Guide available at our homepage which shows you how to integrate the free Demo Version of AGEphone Web Sidebar / Web Support into your page or blog in a few simple steps.
Although integration is very fast and easy, strong security measures prevent your data from being abused:
• All account information required can be encrypted.
• AGEphone Web Sidebar / Web Support will only work on the page you specify. If the code is copied and pasted into another page, it won't run.
Application Fields
Possible fields of application include:
Community/Web 2.0:
• Community sites offering a service to quickly call your friends.
• Integration into a blog to communicate with your readers.
Business/Service:
• Let your customers call you for free by a single click when viewing your webpage.
• You can also call your customers back via the Web Sidebar.
• Dynamically alter the contents of the page your clients are viewing upon call events.
"AGEphone BLOG" at blogger.com has an article on possible application scenarios. Review it for some interesting ideas. Many more setups are possible!
Products and Services offered by ageet
ageet Corporation offers the following products and services to interested enterprises such as blog/community sites and any company seeking direct contact to their customers over the Internet:
• AGEphone Web Sidebar;
• AGEphone Web Support;
• microSIP Web SDK;
• Individual Software Cutomization of these products;
• Software Development based on / related to these products.
The products are available from 09/20/2006. Free demo versions are available for testing and integrating into your page. Contact ageet for details.
Related Materials and Demos - available on our website.
• AGEphone Web Sidebar Live Demo - Test it yourself!
• AGEphone Web Support Live Demo for an online support scenario on ageet.com/.
• Discussion of possible application scenarios and Live Demo for integration into a weblog at blogger.com/.
• Integration Guide for the Demo Versions of AGEphone Web Sidebar and AGEphone Web Support - Try it on your own page!
About ageet Corporation
Head Office Address: 2-64 Yamanawate Terado-cho Mukou City Kyoto, 617-0002 Japan Representative Director: Masato Okazaki - Established: July 2005 Capital: 18 Million Yen
A PDF version of this press release is available. A HTML version of this press release is available. Please visit our website for details.
|